* Long Live PhoneGap for BlackBerry

Posted on July 30th, 2009 by Dave Johnson. Filed under phonegap.


There have been some new developments in the PhoneGap on BlackBerry breathing new life into the project! It all boils down to the fact that in RIM OS >= 4.6 there is a browser rendering option that you can set to make the browser render using the modern rendering engine rather than the archaic one from OS 4.2.

It look something like this:

_renderingSession.getRenderingOptions().setProperty(
  RenderingOptions.CORE_OPTIONS_GUID, 17000, true);

After much trial and error it was found that the BrowserContentManager did not support this rendering option (and RIM says it is completely unsupported / experimental anyhow) yet the Field returned from BrowserContent.getDisplayableContent() does support it!

Long story short it looks like PhoneGap on RIM OS >= 4.6 is going to work really well.

Next up is looking at the new features in OS 5.0.

Tags: , , ,



5 Responses to “Long Live PhoneGap for BlackBerry”

  1. Ethan0026 Says:

    Good Work !! when you can release it ?

  2. Ethan0026 Says:

    GREAT JOB !
    I just have 2 question

    1/ when can you release the phonegap src with the modification ?

    and

    2/ I have downloaded the new pack on phonegap website (released 4 days ago) and i installed it, builded it etc… but finally the emulator run but there is no application “phonegap” anywhere… can you help me ?

    thank a lot

    Ethan

  3. Dave Johnson Says:

    The latest BB code can be retrieved at github.com/filmaj.

    Getting the emulator running can take a bit of practice … I have heard of people needing to delete all the temp files created between simulator runs. Otherwise there are just some switches you can fiddle with in the eclipse blackberry project properties. Wish I could offer more on that topic!

  4. David Aurelio Says:

    Thanks for sharing this.

    Did the code made it in your repo? Compiling the project didn’t seem to work too well. Could you point me in the right direction?

    Thank you, David

  5. Dave Johnson Says:

    @David you should get the code from http://github.com/phonegap - there is a submodule called phonegap-blackberry that should work pretty well for you!

    Check out the wiki too http://wiki.phonegap.com

Trackback URI | Comments RSS

Leave a Reply